再配送



●前置き

 個人でルータ等をオークションで入手し、キャリアデザイン塾さんのサイトを参照して自習用として、また、その結果を記載しています。
 キャリアデザイン塾はルータの設定を一切したことのない人にとっては非常に有用なサイトです。
 みなさんも是非参照してチャレンジしてはいかがでしょうか。CCNA資格取得講習等に高いお金を支払うより、そのお金で中古ルータを数台購入してキャリアデザイン塾のサイトを利用する方がおおいに有用です。

●基本ネットワーク

 最初ネットワークは下記の通りです。

experiment1-x.png

 これから様々な実験をしてみたいと思います。
 上記のままではdfgwからPCへのpingは通りません。通るようにルーティングを設定します。

 「dfgw」の初期ルーティングテーブル
dfgw#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S*    0.0.0.0/0 is directly connected, Dialer0
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Vlan3
L        192.168.0.254/32 is directly connected, Vlan3
 「catalyst3750-1」の初期ルーティングテーブル
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 「Router_A」の初期ルーティングテーブル
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Loopback0
L        10.0.0.1/32 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1
 「Router_B」の初期ルーティングテーブル
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
 「catalyst3750-2」の初期ルーティングテーブル
catalyst3750-2#sh ip route
Gateway of last resort is not set
C    172.17.0.0/16 is directly connected, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
 上記の状態ではdfgwから1.0.0.254にpingを打っても応答は返って来ません。もちろんそれよりも遠いアドレスからも応答は返ってくることはありません。
 catalyst3750-1からは同じネットワークと認識される192.168.0.254、1.0.0.241からはpingは返って来ますが、172.16.1.1からはpingは返って来ません。Router_A、Router_Bにおいても自分自身が属していないネットワークへpingを打っても応答は返って来ないことになります。

 設定変更により、これらのルーティングテーブルがどのように変わっていくか見ていきます。

●RIPの設定

 順にRIPを設定します。まずは、「dfgw」のRIPを設定します。
!
hostname dfgw
!
router rip
 version 2
 network 192.168.0.0
 no auto-summary
!
 「dfgw」のルーティングテーブル
dfgw#sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S*    0.0.0.0/0 is directly connected, Dialer0
R     1.0.0.0/8 [120/1] via 192.168.0.253, 00:00:25, Vlan3
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Vlan3
L        192.168.0.254/32 is directly connected, Vlan3
 「1.0.0.0/8」の情報が伝わって来ました。これによりdfgwから1.0.0.254から応答が返って来ます。しかし、1.0.0.241からはまだ応答が返って来ません。これは1.0.0.241から見た場合、192.168.0.0/24がどこのネットワークなのか知らないためです。
dfgw#ping 1.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
dfgw#ping 1.0.0.241
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.241, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
 dfgwから1.0.0.241への応答が返ってくるようにするためRouter_AにRIPを設定します。
!
router rip
 version 2
 network 1.0.0.0
 network 172.16.0.0
!
 しかし、ルーティングテーブルに変更はありません。
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
 次に、catalyst3750-1にRIPを設定します。
!
router rip
 version 2
 network 1.0.0.0
 network 192.168.0.0
!
 catalyst3750-1のルーティングテーブルは下記のように変わります。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
R    172.16.0.0/16 [120/1] via 1.0.0.241, 00:00:18, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 172.16.0.0/16を学習しているのが分かります。dfgw及びRouter_Aのルーティングテーブルも書き換えられます。
dfgw#sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S*    0.0.0.0/0 is directly connected, Dialer0
R     1.0.0.0/8 [120/1] via 192.168.0.253, 00:00:08, Vlan3
R     172.16.0.0/16 [120/1] via 192.168.0.253, 00:00:08, Vlan3
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Vlan3
L        192.168.0.254/32 is directly connected, Vlan3
 dfgwでも172.16.0.0/16を学習しています。
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
R     192.168.0.0/24 [120/1] via 1.0.0.254, 00:00:18, Vlan2
 Router_Aに192.168.0.0/24でも学習しているのが分かります。
 これによりdfgwから1.0.0.241に対するpingが応答が返ってきます。さらに172.16.1.1からもpingの応答が返ってきます。Router_Aから192.168.0.254へpingを打っても返ってくるようになります。
dfgw#ping 1.0.0.241 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.241, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
dfgw#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
Router_A#ping 192.168.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
 Router_A、catalyst3750-2にもRIPを設定することにより、dfgwから端末(172.18.1.10)へ通信が出来るようになります。
Router_B#sh ru
!
router rip
 version 2
 network 172.16.0.0
 network 172.17.0.0
!
BRouter_B#sh ip route
R     1.0.0.0/8 [120/1] via 172.16.1.1, 00:00:03, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
R     192.168.0.0/24 [120/2] via 172.16.1.1, 00:00:03, Vlan10
dfgw#ping 172.17.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
Router_B#ping 192.168.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 catalyst3750-2もRIPを設定します。
catalyst3750-2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R    1.0.0.0/8 [120/2] via 172.17.1.1, 00:00:02, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
R    172.16.0.0/16 [120/1] via 172.17.1.1, 00:00:02, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
R    192.168.0.0/24 [120/3] via 172.17.1.1, 00:00:02, Vlan20
dfgw#sh ip route
Gateway of last resort is 0.0.0.0 to network 0.0.0.0
S*    0.0.0.0/0 is directly connected, Dialer0
R     1.0.0.0/8 [120/1] via 192.168.0.253, 00:00:05, Vlan3
R     172.16.0.0/16 [120/1] via 192.168.0.253, 00:00:05, Vlan3
R     172.17.0.0/16 [120/3] via 192.168.0.253, 00:00:05, Vlan3
R     172.18.0.0/16 [120/4] via 192.168.0.253, 00:00:05, Vlan3
      192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.0.0/24 is directly connected, Vlan3
L        192.168.0.254/32 is directly connected, Vlan3
dfgw#ping 172.18.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.18.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
 もちろん、端末から192.168.0.254へpingは通るようになり、スイッチで設定されているネットワーク上の端末もpingが通るようになります。
 最終的にcatalyst3750-1、Router_A、Router_Bのルーティングテーブルは下記のようになります。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
R    172.17.0.0/16 [120/2] via 1.0.0.241, 00:00:16, Vlan2
R    172.16.0.0/16 [120/1] via 1.0.0.241, 00:00:16, Vlan2
R    172.18.0.0/16 [120/3] via 1.0.0.241, 00:00:16, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
R     172.17.0.0/16 [120/1] via 172.16.1.2, 00:00:22, FastEthernet0
R     172.18.0.0/16 [120/2] via 172.16.1.2, 00:00:22, FastEthernet0
R     192.168.0.0/24 [120/1] via 1.0.0.254, 00:00:27, Vlan2
Router_B#sh ip route
Gateway of last resort is not set
R     1.0.0.0/8 [120/1] via 172.16.1.1, 00:00:19, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
R     172.18.0.0/16 [120/1] via 172.17.1.2, 00:00:08, Vlan20
R     192.168.0.0/24 [120/2] via 172.16.1.1, 00:00:19, Vlan10

●OSPFの設定

 図のRouter_A、Router_B、catalyst3750-2のルーティングプロトコルをRIPを有効のままOSPFを設定します。

experiment2-x.png

 作業前のルーティングテーブル
catalyst3750-2#sh ip route
Gateway of last resort is not set
R    1.0.0.0/8 [120/2] via 172.17.1.1, 00:00:22, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
R    172.16.0.0/16 [120/1] via 172.17.1.1, 00:00:22, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
R    192.168.0.0/24 [120/3] via 172.17.1.1, 00:00:22, Vlan20
Router_B#sh ip route
Gateway of last resort is not set
R     1.0.0.0/8 [120/1] via 172.16.1.1, 00:00:19, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
R     172.17.0.0/16 [120/1] via 172.16.1.2, 00:00:22, FastEthernet0
R     172.18.0.0/16 [120/2] via 172.16.1.2, 00:00:22, FastEthernet0
R     192.168.0.0/24 [120/1] via 1.0.0.254, 00:00:27, Vlan2
 catalyst3750-2でOSPFを設定します。
!
router ospf 1
 log-adjacency-changes
 network 172.17.0.0 0.0.255.255 area 0
 network 172.18.0.0 0.0.255.255 area 0
!
 設定変更後はまだ、Router_B、catalyst3750-2のルーティングテーブルに変わりはありません。では、Router_BでもOSPFを設定します。
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
 network 172.17.0.0 0.0.255.255 area 0
!
 では、catalyst3750-2、Router_Bのルーティングテーブルを見てみましょう。
catalyst3750-2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
     1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
R    1.0.0.0/8 [120/2] via 172.17.1.1, 00:00:02, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
O    172.16.0.0/16 [110/2] via 172.17.1.1, 00:00:42, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
R    192.168.0.0/24 [120/3] via 172.17.1.1, 00:00:02, Vlan20
Router_B#sh ip route
Gateway of last resort is not set
R     1.0.0.0/8 [120/1] via 172.16.1.1, 00:00:24, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
O     172.18.0.0/16 [110/2] via 172.17.1.2, 00:01:58, Vlan20
R     192.168.0.0/24 [120/2] via 172.16.1.1, 00:00:24, Vlan10
 アドミニストレーティブディスタンスがOSPFの「110」に変わっています。

 アドミニストレーティブディスタンスについては、アドミニストレーティブ ディスタンスの概要を参照してください。

 この時、OSPF設定前後でcatalyst3750-1のルーティングテーブルが以下のように異なっていることが分かります。
OSPF設定前
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
R    172.17.0.0/16 [120/2] via 1.0.0.241, 00:00:16, Vlan2
R    172.16.0.0/16 [120/1] via 1.0.0.241, 00:00:16, Vlan2
R    172.18.0.0/16 [120/3] via 1.0.0.241, 00:00:16, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
OSPF設定後
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
R    172.17.0.0/16 [120/2] via 1.0.0.241, 00:00:09, Vlan2
R    172.16.0.0/16 [120/1] via 1.0.0.241, 00:00:09, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 ルーティングテーブルから172.18.0.0/16の情報が消えていることが分かります。catalyst3750-1から172.18.1.1へpingを打っても応答はありません。
catalyst3750-1#ping 172.17.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.17.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
 Router_AでOSPFを設定します。
!
router ospf 1
 network 172.16.0.0 0.0.255.255 area 0
!
 また、Router_AでRIPから172.16.0.0/16の情報を削除します。
!
router rip
 version 2
 network 1.0.0.0
!
 これで図のようなRouter_Aを境界ルータとしたRIPルーティングゾーンとOSPFルーティングゾーンが完成したことになります。この時のRouter_A、catalyst3750-1のルーティングテーブルを確認してみると、catalyst3750-1から172.16.0.0/16、172.17.0.0/16、172.18.0.0/16のRIP情報が消えていることが分かります。
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
O     172.17.0.0/16 [110/2] via 172.16.1.2, 00:07:30, FastEthernet0
     172.18.0.0/16 [110/3] via 172.16.1.2, 00:07:30, FastEthernet0
R     192.168.0.0/24 [120/1] via 1.0.0.254, 00:00:19, Vlan2
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1

●再配送について

 ルート再配送(Redistribution)とは、異なるルーティングプロトコル間でルート情報を交換する場合に用いる手法です。例えば、下図のような構成で再配送を行っていない場合は、RIPはOSPFのルート情報を、OSPFはRIPのルート情報を知ることができません。

experiment2-1-x.png

 RIPとOSPFの両方のルーティングプロトコルが動作している境界のルータで再配送をすることで、異なるルーティングプロトコル間を接続することができます。

experiment2-2-x.png

 再配送が必要になるのは下記のとおりです。
  1. マルチベンダ環境(EIGRPやOSPFの混在)
  2. ハードウェアのスペックにルーティングプロトコルが依存する(OSPFが動かせないルータ等)
  3. 別のルーティングプロトコルに移行する時
  4. その他、複数のルーティングプロトコルを使用する
 単純に複数のルーティングプロトコルを動かす時に必要になる可能性があります。
  1. マルチベンダ環境(EIGRPやOSPFの混在)
  2. 管理しているネットワーク全体の機器をすべて一つのベンダに統一するのは難しいです。ベンダ独自のプロトコルを動作させる場合には、複数のルーティングプロトコルが混在する事になり、各プロトコル間の経路情報を再配送する必要があります。
  3. ハードウェアのスペックにルーティングプロトコルが依存する(OSPFが動かせないルータ等)
  4. ネットワークは、常に最新のハードウェアを使用することは不可能です。年月とともに複雑に大きくなっていく可能性が高いです。例えば建て増しの古い家屋の様に。そのため、古い機器と新しい機器が混在し、古い機器ではOSPFを動作させるリソースが少ない場合には、複数のルーティングプロトコルを動作させる必要がでてきます。
  5. 別のルーティングプロトコルに移行する時
  6. ネットワークは常に進化しています。成長する企業でRIPを常に使い続けるという選択肢はないです。企業が成長すればネットワークも基本的に成長します。そうすると当初RIPであったネットワークをOSPFやEIGRP等の大規模ネットワークに対応できるルーティングプロトコルに移行したいという要求はでてきます。移行する時に、一気にRIPからOSPFへ移行するのは難しです。既存のRIPから徐々にOSPFへ移行していく 途中にルート情報の再配送が必要になります。
  7. その他、複数のルーティングプロトコルを使用する
  8. ルーティングプロトコルを統一できない場合は、再配送を考慮する必要があります。ネットワーク管理範囲が違い場合(自社とISP)や企業合併、部門の譲渡によるネットワーク移行などの場合でも必要になります。
 ネットワークが成長しない(企業の成長もなし?)、または初期の設計が将来の変化を考慮している場合にはルーティングプロトコルを複数混在させる必要がなく、再配送も不要です。(成長しなくてもM&Aなどで切り売りされた場合でもネットワークは変化せざる得ないです)出来れば再配送という複雑なことをしないで済むように設計/構築/運用をしたいところです。

●OSPF→RIP再配送

 参照URL:ルーティング プロトコルの再配送

 想定するネットワークは下記のとおりです。

experiment3-x.png

 再配送の設定をします。再配送を行う時には、どのルーティングプロトコルの経路情報をどのルーティングプロトコルへ再配送するか理解している必要があります。今回はOSPFからRIPですので、RIPのルータコンフィグレーションモードで、redistribute {配送したいルーティングプロトコル} を使用し設定します。
Router_A(config)#router rip
Router_A(config-router)#redistribute ospf 1
 catalyst3750-1に経路情報が届いているか確認します。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 どうやら届いていないようです。再配送設定の確認をします。
Router_A#debug ip rip
Router_A#sh log
Mar  4 10:30:22.171: RIP: sending v2 update to 224.0.0.9 via Vlan2 (1.0.0.241)
Mar  4 10:30:22.171: RIP: build update entries - suppressing null update
Mar  4 10:30:35.724: RIP: received v2 update from 1.0.0.254 on Vlan2
Mar  4 10:30:35.724:      192.168.0.0/24 via 0.0.0.0 in 1 hops
Mar  4 10:30:48.264: RIP: sending v2 update to 224.0.0.9 via Vlan2 (1.0.0.241)
Mar  4 10:30:48.264: RIP: build update entries - suppressing null update
Mar  4 10:31:01.972: RIP: received v2 update from 1.0.0.254 on Vlan2
Mar  4 10:31:01.972:      192.168.0.0/24 via 0.0.0.0 in 1 hops
 これは再配送設定に、メトリック設定を入れていないためです。RIPとOSPFのメトリックは、RIPはホップ数、OSPFはコストとメトリックが違うので、再配送では異なるルーティングプロトコルのメトリックを再配送先のメトリックに置き換える必要があります。例えばOSPFのコストが100で、100というコストをホップ数に置き換えるとRIPでは無効なメトリックになります。単純に置き換えることはできないということです。
 再配送をする際に、メトリックを指定しない場合は、デフォルトのメトリックが自動的に設定されます。再配送する際の最初のメトリック値のことを特にシードメトリックといいます。RIPへ再配送する際のデフォルトのシードメトリックは、「∞」です。メトリックが「∞」時には、無効な経路情報とされます。以下に各ルーティングプロトコルに対するデフォルトのシードメトリックを記載します。

ルーティングプロトコル デフォルトのシードメトリック値
RIP ∞ (無効なルート)
IGRP/EIGRP ∞ (無効なルート)
OSPF 20
Integrated IS-IS 0 (有効なルート)
BGP IGPのメトリックを保持

 シードメトリックを考慮して、再配送設定をもう一度します。
Router_A(config)#router rip
Router_A(config-router)#redistribute ospf 1 metric 5
 catalyst3750-1の経路情報を確認します。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
R    172.17.0.0/16 [120/5] via 1.0.0.241, 00:00:02, Vlan2
R    172.16.0.0/16 [120/5] via 1.0.0.241, 00:00:02, Vlan2
R    172.18.0.0/16 [120/5] via 1.0.0.241, 00:00:02, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 Router_Aで再配送の確認をします。
Router_A#debug ip rip
Router_A#sh log
Mar  4 10:52:50.941: RIP: received v2 update from 1.0.0.254 on Vlan2
Mar  4 10:52:50.941:      192.168.0.0/24 via 0.0.0.0 in 1 hops
Mar  4 10:53:16.881: RIP: sending v2 update to 224.0.0.9 via Vlan2 (1.0.0.241)
Mar  4 10:53:16.881: RIP: build update entries
Mar  4 10:53:16.881: 	172.16.0.0/16 via 0.0.0.0, metric 5, tag 0
Mar  4 10:53:16.881: 	172.17.0.0/16 via 0.0.0.0, metric 5, tag 0
Mar  4 10:53:16.881: 	172.18.0.0/16 via 0.0.0.0, metric 5, tag 0
 設定状態を確認するには、「show ip protocols」を使用します。
Router_A#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 7 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip, ospf 1
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    Vlan2                 2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    1.0.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2           120      13:08:10
    1.0.0.254            120      00:00:15
  Distance: (default is 120)
 OSPFプロセス番号「1」を再配送することがわかります。
 ここまでの設定では、OSPFからRIPへの一方向の再配送になり、catalyst3750-1からRouter_BへPing疎通を確認してもトラフィックは戻ってきません。相互に再配送するか、Router_Bにデフォルトルートの設定する必要があります。

●RIP→OSPF再配送

 参照URL:ルーティング プロトコルの再配送

 想定ネットワークは下記のとおりです。

experiment4-x.png

 再配送の設定をします。OSPFのルータコンフィグレーションモードで redistribute {配送したいルーティングプロトコル} を使用し設定します。配送先プロトコルのルータコンフィグレーションモードで再配送の設定をすることに注意です。
Router_A(config)#router ospf 1
Router_A(config-router)#redistribute rip
% Only classful networks will be redistributed
 シードメトリックの設定をしていません。RIPやIGRP/EIGRPへの再配布ではシードメトリックを指定しない場合、デフォルトで「∞」メトリックになるでアドバタイズされません。ただし、OSPFへの再配送はデフォルトで「20」が設定されます。
 また、「% Only classful networks will be redistributed」はクラスフルネットワークだけが再配送されるという注意メッセージです。 設定確認のために、Router_Bのルーティングテーブルを確認します。
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
O     172.18.0.0/16 [110/2] via 172.17.1.2, 17:17:27, Vlan20
O E2  192.168.0.0/24 [110/20] via 172.16.1.1, 00:10:31, Vlan10
 Router_Bのルーティングテーブルには、再配送された192.168.0.0/24の経路情報が伝搬されています。メトリックはデフォルトのシードメトリック「20」になっています。しかしながら「1.0.0.0/24」の経路情報が見当たりません。再配送設定の時に「% Only classful networks will be redistributed」というメッセージにある通り、クラスフルネットワークだけを再配送しています。サブネット化されたネットワークを再配送するために、再配送設定時に「subnets」オプションを指定する必要があります。「subnets」オプションを付けて、再度設定を行います。シードメトリックも「10」に変更します。
Router_A(config)#router ospf 1    
Router_A(config-router)#redistribute rip metric 10 subnets
 シードメトリックが「10」で、サブネットオプションを付けて再度設定を行いました。今度は、「% Only classful networks will be redistributed」というメッセージは表示されませんでした。この設定でRouter_Bへサブネット化された経路情報がアドバタイズされたか確認します。
Router_B#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O E2     1.0.0.0 [110/10] via 172.16.1.1, 00:00:30, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
O     172.18.0.0/16 [110/2] via 172.17.1.2, 17:25:55, Vlan20
O E2  192.168.0.0/24 [110/10] via 172.16.1.1, 00:00:30, Vlan10
 サブネット化されたネットワークもしっかりと再配送されたのが確認できます。メトリックもシードメトリックで設定した「10」でアドバタイズされています。経路情報の「E2」は外部ネットワーク(再配送されたネットワーク)のメトリックタイプです。

●EIGRPの設定

 図のRouter_A、Router_B、catalyst3750-2のルーティングプロトコルをOSPFを有効のままEIGRPを設定します。

experiment5-x.png

 作業前のルーティングテーブル
catalyst3750-2#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
O       1.0.0.0 [110/3] via 172.17.1.1, 00:05:35, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
O    172.16.0.0/16 [110/2] via 172.17.1.1, 00:05:35, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
O    192.168.0.0/24 [110/4] via 172.17.1.1, 00:05:35, Vlan20
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 00:08:19, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
O     172.18.0.0/16 [110/2] via 172.17.1.2, 00:06:05, Vlan20
O     192.168.0.0/24 [110/3] via 172.16.1.1, 00:08:19, Vlan10
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
O     172.17.0.0/16 [110/2] via 172.16.1.2, 00:08:47, FastEthernet0
O     172.18.0.0/16 [110/3] via 172.16.1.2, 00:06:44, FastEthernet0
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:12:30, Vlan2
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.17.0.0/16 [110/3] via 1.0.0.241, 00:07:46, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 00:07:46, Vlan2
O    172.18.0.0/16 [110/4] via 1.0.0.241, 00:07:46, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 catalyst3750-2でEIGRPを設定します。
!
router eigrp 1
 network 172.17.0.0
 network 172.18.0.0
!
 設定変更後はまだ、Router_B、catalyst3750-2のルーティングテーブルに変わりはありません。では、Router_BでもEIGRPを設定します。
!
router eigrp 1
 network 172.16.0.0
 network 172.17.0.0
!
 では、catalyst3750-2、Router_Bのルーティングテーブルを見てみましょう。
catalyst3750-2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
O E2    1.0.0.0 [110/10] via 172.17.1.1, 19:03:21, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
D    172.16.0.0/16 [90/28416] via 172.17.1.1, 00:07:16, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
O E2 192.168.0.0/24 [110/10] via 172.17.1.1, 19:03:21, Vlan20
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O E2     1.0.0.0 [110/10] via 172.16.1.1, 19:01:37, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
D     172.18.0.0/16 [90/28416] via 172.17.1.2, 00:05:33, Vlan20
O E2  192.168.0.0/24 [110/10] via 172.16.1.1, 19:01:37, Vlan10
 アドミニストレーティブディスタンスが「90」に変わっています。この時、EIGRP設定前後でcatalyst3750-1のルーティングテーブルに変化はありません。

 アドミニストレーティブディスタンスについては、アドミニストレーティブ ディスタンスの概要を参照してください。

 catalyst3750-2、Router_BからOSPFの設定を削除します。この時のcatalyst3750-2、Router_B、Router_A、catalyst3750-1の経路情報は下記のようになります。
catalyst3750-2#sh ip route
Gateway of last resort is not set
C    172.17.0.0/16 is directly connected, Vlan20
D    172.16.0.0/16 [90/28416] via 172.17.1.1, 00:01:01, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
D     172.18.0.0/16 [90/28416] via 172.17.1.2, 00:04:07, Vlan20
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:30:07, Vlan2
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 00:06:19, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 最後に境界ルータRouter_AでEIGRPを設定します。
!         
router eigrp 1
 network 172.16.0.0
!
router ospf 1
 network 1.0.0.0 0.0.0.255 area 0
!
 この時、catalyst3750-2、Router_B、Router_A、catalyst3750-1の経路情報は下記のように変化します。
catalyst3750-2#sh ip route 
Gateway of last resort is not set
C    172.17.0.0/16 is directly connected, Vlan20
D    172.16.0.0/16 [90/28416] via 172.17.1.1, 00:18:06, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
D     172.18.0.0/16 [90/28416] via 172.17.1.2, 00:18:03, Vlan20
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
D     172.17.0.0/16 [90/30720] via 172.16.1.2, 00:04:13, FastEthernet0
D     172.18.0.0/16 [90/30976] via 172.16.1.2, 00:04:13, FastEthernet0
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:43:43, Vlan2
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 Router_A、catalyst3750-1のルーティングテーブルを確認してみると、Router_Aでは172.17.0.0/16、172.18.0.0/16が伝搬されており、catalyst3750-1からOSPFの情報が消えていることが分かります。これで図のようなRouter_Aを境界ルータとしたOSPFルーティングゾーンとEIGRPルーティングゾーンが完成したことになります。

●EIGRP→OSPF再配送

 参照URL:ルーティング プロトコルの再配送

 想定するネットワークは下記のとおりです。

experiment6-x.png

 サブネットも含めて再配送の設定をします。
Router_A(config)#router ospf 1
Router_A(config-router)#redistribute eigrp 1 subnet

 設定確認のために、Router_Aの「show ip protocols」を確認します。「Redistributing ospf 1」とあります。再配送の設定が行われているのがわかります。
Router_A#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    eigrp 1, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.0.0.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.253        110      1d02h
    172.18.1.1           110      1d02h
  Distance: (default is 110)
  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      02:35:00
  Distance: internal 90 external 170
 EIGRP 1をサブネットも含めて再配送すると表示されています。
 catalyst3750-1に経路情報が届いているか確認します。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O E2 172.17.0.0/16 [110/20] via 1.0.0.241, 00:00:29, Vlan2e
O E2 172.16.0.0/16 [110/20] via 1.0.0.241, 00:00:29, Vlan2e
O E2 172.18.0.0/16 [110/20] via 1.0.0.241, 00:00:29, Vlan2e
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 172.16.0.0/16、172.17.0.0/16、172.18.0.0/16が伝搬されてきているのが分かります。  しかし、catalyst3750-1から172.16.1.2へpingしても応答はありません。
catalyst3750-1#ping 172.16.1.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
 これは、Router_Bで1.0.0.0/24への経路情報がないためです。Router_AでEIGRPに向けてOSPFの再配送を設定する必要があります。
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
D     172.18.0.0/16 [90/28416] via 172.17.1.2, 19:50:53, Vlan20

●OSPF→EIGRP再配送

 参照URL:ルーティング プロトコルの再配送

 想定ネットワークは下記のとおりです。他の再配送(Redistribute)と同様で、再配送先のルーティングプロトコルのルータコンフィグレーションモードで redistribute {配送したいルーティングプロトコル}を使用し設定します。EIGRPはRIPと同じく、シードメトリックの指定がない場合には、メトリックが「∞」となり無効なルートのため再配送されません。シードメトリックは指定する必要があります。
 シードメトリックの指定には、ルータコンフィグレーションモードで「default-metric {metric value}」か「redistribute {routing protocol} metric {metric value}」のどちらかのコマンドを使用します。前者はEIGRPへ再配送される全てのプロトコルについてのシードメトリックの指定になります。後者はredistributeコマンドで指定したプロトコルごとに、シードメトリックを指定できます。
 EIGRPのシードメトリック指定は、EIGRPのメトリックの要素である帯域幅、遅延、信頼性、負荷、MTUのすべてを指定する必要があります。

experiment7-x.png

 再配送の設定をします。
Router_A(config)#router eigrp 1
Router_A(config-router)#redistribute ospf 1 metric 100000 10 255 1 1500
※数値の説明
100000:帯域幅(Kbit単位)
10:遅延(10マイクロ秒単位)
255:信頼性(255=100%信頼)
1:負荷(1=負荷なし)
1500:MTU
 上記の例では、帯域幅の単位はKbit単位になり100Mbps、遅延は10μ秒単位になり100μ秒になります。
 設定確認のために、Router_Aの「show ip protocols」を確認します。「Redistributing ospf 1」とあります。再配送の設定が行われているのがわかります。
Router_A#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  Redistributing: ospf 1
  EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 192.168.1.1
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      02:35:00
  Distance: internal 90 external 170
 Router_B、catalyst3750-2の経路情報を確認します。
Router_B#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
D EX     1.0.0.0 [170/30720] via 172.16.1.1, 00:01:46, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
D     172.18.0.0/16 [90/28416] via 172.17.1.2, 20:09:47, Vlan20
D EX  192.168.0.0/24 [170/30720] via 172.16.1.1, 00:01:46, Vlan10
catalyst3750-2#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
D EX    1.0.0.0 [170/30976] via 172.17.1.1, 00:06:37, Vlan20
C    172.17.0.0/16 is directly connected, Vlan20
D    172.16.0.0/16 [90/28416] via 172.17.1.1, 20:15:48, Vlan20
C    172.18.0.0/16 is directly connected, Vlan30
D EX 192.168.0.0/24 [170/30976] via 172.17.1.1, 00:06:37, Vlan20
 OSPFにある経路情報を学習していることがわかります。経路情報にEXとあり、これは外部ネットワークの経路情報であることを示しています。アドミニストレーティブディスタンス値もEIGRPの内部「90」ではなく、外部ネットワークの「170」になっています。
 これで、catalyst3750-1から172.18.1.1へのping、catalyst3750-2から1.0.0.254へのpingも応答可能となります。
catalyst3750-1#ping 172.18.1.10
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.18.1.10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms
catalyst3750-2#ping 1.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/4/9 ms

●ISISの設定

 想定しているネットワークは下記のとおりです。

experiment8-x.png

 まず、Router_A、Router_BでISISルーティングを設定します。
Router_Aの設定
!
interface FastEthernet0
 ip address 172.16.1.1 255.255.0.0
 ip router isis 
 duplex auto
 speed auto
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-1
!
Router_Bの設定
!
interface Vlan10
 ip address 172.16.1.2 255.255.0.0
 ip router isis 
!
interface Vlan20
 ip address 172.17.1.1 255.255.0.0
 ip router isis 
!
router isis
 net 49.0001.2222.2222.2222.00
 is-type level-1
!
 この時のcatalyst3750-1、Router_A、Router_Bのルーティングテーブルは下記のとおりです。
catalyst3750-1#sh ip route 
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
i L1  172.17.0.0/16 [115/20] via 172.16.1.2, 00:08:02, FastEthernet0
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:15:57, Vlan2
catalyst3750-1#sh ip route 
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 Router_AでRouter_Bからの経路172.17.0.0/16、catalyst3750-1からの経路192.168.0.0/24を学習している事が分かります。この時点ではcatalyst3750-1とRouter_Bにはお互いの経路情報は伝搬されていません。
 catalyst3750-2でもISISルーティングを設定します。と思いましたがIOSイメージがISISに対応していませんでした・・。ということでネットワーク構成を変更し、Router_Cを追加します。Router_CでもISISを動作させます。
!
interface FastEthernet0
 ip address 172.40.1.2 255.255.0.0
 ip router isis 
 duplex auto
 speed auto
!
router isis
 net 49.0001.3333.3333.3333.00
 is-type level-1
!
 Router_A、Router_B、Router_Cのルーティングテーブルは下記のとおりです。
Router_A#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, Loopback0
L        10.0.0.1/32 is directly connected, Loopback0
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
i L1  172.17.0.0/16 [115/20] via 172.16.1.2, 00:27:51, FastEthernet0
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.30.0.0/16 is directly connected, Async5
L        172.30.0.1/32 is directly connected, Async5
C        172.30.0.2/32 is directly connected, Async5
i L1  172.40.0.0/16 [115/20] via 172.16.1.2, 00:27:51, FastEthernet0
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:27:51, Vlan2
      192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.1.0/24 is directly connected, Loopback1
L        192.168.1.1/32 is directly connected, Loopback1
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.30.0.0/16 is directly connected, Async5
C        172.30.0.1/32 is directly connected, Async5
L        172.30.0.2/32 is directly connected, Async5
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
Router_C#sh ip route
Gateway of last resort is not set
i L1  172.16.0.0/16 [115/20] via 172.40.1.1, 03:31:50, FastEthernet0
i L1  172.17.0.0/16 [115/20] via 172.40.1.1, 03:31:50, FastEthernet0
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.2/32 is directly connected, FastEthernet0
 catalyst3750-1からRouter_A(172.16.1.1)へpingを打ってみます。
catalyst3750-1#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
 応答がありません。Router_Bからcatalyst3750-1(1.0.0.254)へpingを打ってみます。
Router_B#ping 1.0.0.254
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1.0.0.254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
 この場合も応答がありません。もちろんRouter_Cからcatalyst3750-1へpingを打っても応答はありません。

●OSPF→ISISの設定

 参照URL:ルーティング プロトコルの再配送

 想定するネットワークは下記のとおりです。

experiment9-x.png

 再配送の設定をします。
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-1
 redistribute ospf 1
!
 設定確認のために、Router_Aの「show ip protocols」とRouter_Bのルーティングテーブルを確認します。
Router_A#sh ip prot
*** IP Routing is NSF aware ***
Routing Protocol is "isis"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: isis, ospf 1
  Address Summarization:
    None
  Maximum path: 4
  Routing for Networks:
    FastEthernet0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.40.1.2           115      00:13:43
    172.17.1.1           115      00:13:43
    172.16.1.2           115      22:47:33
  Distance: (default is 115)
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.0.0.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.253        110      19:26:57
  Distance: (default is 110)
「Redistributing: isis」とあり、再配送の設定が行われているのがわかります。
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.30.0.0/16 is directly connected, Async5
C        172.30.0.1/32 is directly connected, Async5
L        172.30.0.2/32 is directly connected, Async5
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
 Router_Bのルーティングテーブルは再配送されているはずの経路情報を学習していません。
 これは、IS-ISにはレベルと言う概念があり、再配送の設定時にレベルを指定しないとデフォルトでレベル2ルーティングへの再配送になってしまいます。構成図のIS-ISネットワークはレベル1ルーティングに設定してあるので、再配送されないと言うことになります。
 では、IS-ISのレベル1ルーティングへ再配送するために設定変更を行います。
 「redesitribute」コマンドに続けて、レベルを指定します。指定できるレベルは、「level-1」「level-2」「level-1-2」の三つになります。
!
router isis
 net 49.0001.1111.1111.1111.00
 is-type level-1
 redistribute ospf 1 level-1
!
再配送した経路情報をRouterCが学習しているか確認します。
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
i L1     1.0.0.0 [115/10] via 172.16.1.1, 00:00:03, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.30.0.0/16 is variably subnetted, 3 subnets, 2 masks
C        172.30.0.0/16 is directly connected, Async5
C        172.30.0.1/32 is directly connected, Async5
L        172.30.0.2/32 is directly connected, Async5
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
i L1  192.168.0.0/24 [115/10] via 172.16.1.1, 00:00:03, Vlan10
 再配送された経路情報を学習しているがわかります。シードメトリックは「0」でしたが、受信したインタフェースでコストが加算されています。IS-ISのインタフェースのコストはデフォルトで「10」です。0 + 10でルーティングテーブルのメトリックは「10」となっています。
 catalyst3750-1からRouter_Cへpingを打っても応答はありません。
catalyst3750-1#ping 172.40.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.40.1.1, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

●ISIS→OSPFの設定

 参照URL:ルーティング プロトコルの再配送

 想定するネットワークは下記のとおりです。

experiment10-x.png

 上記の設定までではRouter_AからRouter_Cへの片方向の再配送となってしまいます。Router_AでISISの経路情報をOSPFへの再配送の設定をします。
 OSPFが再配送先であるので、OSPFのルータコンフィグレーションモードで設定します。再配送する経路情報は、ISISのレベル1を指定します。再配送されるレベルのデフォルトは「level-1-2」になります。確認のためにRouterBの「show ip protocols」とRouterAのルーティングテーブルを確認します。
Router_A#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "isis"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Redistributing: isis, ospf 1
  Address Summarization:
    None
  Maximum path: 4
  Routing for Networks:
    FastEthernet0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.40.1.2           115      00:10:39
    172.17.1.1           115      00:10:39
    172.16.1.2           115      2d00h
  Distance: (default is 115)
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    isis, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.0.0.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.253        110      1d21h
  Distance: (default is 110)
catalyst3750-1#sh ip route    
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O E2 172.17.0.0/16 [110/20] via 1.0.0.241, 00:00:06, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:00:06, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 ISISをサブネットも含めて再配送するとわかりやすく表示されています。
 経路情報は「172.17.0.0/16」と「172.40.0.0/16」が学習されています。「172.16.0.0/16」等は再配送されていません。この点も他のIGPと動作が異なる点です。Router_AのISISから学習した経路情報のみを再配送し、「Connected」は再配送していません。Router_Aでは「172.16.0.0/16」は「Connected」なので、別途「Connected」をOSPFへ再配送する必要があります。
 設定完了後に、再度catalyst3750-1のルーティングテーブルを確認します。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O E2 172.17.0.0/16 [110/20] via 1.0.0.241, 00:13:41, Vlan2
O E2 172.16.0.0/16 [110/20] via 1.0.0.241, 00:00:14, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:13:41, Vlan2
O E2 10.0.0.0/8 [110/20] via 1.0.0.241, 00:00:14, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
O E2 192.168.1.0/24 [110/20] via 1.0.0.241, 00:00:14, Vlan2
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 再配送されたISISの経路情報と、Connectedの経路情報をcatalyst3750-1は学習することができています。catalyst3750-1からRouter_B(172.16.1.1)へpingを打つと応答があります。
catalyst3750-1#ping 172.16.1.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms

●ConnectedとStaticの再配送の設定

 参照URL:ルーティング プロトコルの再配送

 想定するネットワークは下記のとおりです。

experiment11-x.png

 設定条件は
  • Router_Aの直接接続した「172.16.1.0/16」をOSPFへ再配送する
  • Router_Aから「172.40.0.0/16」、「192.168.100.0/24」へはStaticルートを設定する
  • 上記のStaticルートをOSPFへ再配送する
 Router_BのデフォルトルートをRouter_Aに、Router_CのデフォルトルートをRouter_Bに向けます。
Router_Bの設定内容
Router_B#sh ru
!
interface FastEthernet0
 ip address 172.40.1.1 255.255.0.0
 duplex auto
 speed auto
!
interface Vlan10
 ip address 172.16.1.2 255.255.0.0
!
ip route 0.0.0.0 0.0.0.0 172.16.1.1
!
Router_Cの設定内容
Router_C#sh ru
!
interface Loopback0
 ip address 192.168.100.1 255.255.255.0
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet0
 ip address 172.40.1.2 255.255.0.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 172.40.1.1
!

●ConnectedとStaticルートの再配送

 Router_Aのルーティングテーブルの「Connected:172.16.0.0/16」と「Static:172.40.0.0/24」をOSPFへ再配送します。 他の再配送(Redistribute)と同じで、再配送先のルーティングプロトコルのルータコンフィグレーションモードで redistribute {配送したいルーティングプロトコル} を使用し設定します。
Router_A#sh ru
!
router ospf 1
 redistribute connected subnets
 redistribute static subnets
 redistribute eigrp 1 metric 10 subnets
 network 1.0.0.0 0.0.0.255 area 0
!
ip route 172.17.0.0 255.255.0.0 172.16.1.2
ip route 172.40.0.0 255.255.0.0 172.16.1.2
!
 OSPFへの再配送の場合は、シードメトリックがデフォルト「20」です。再配送する経路はサブネット化されていませんが、subnetsオプションを付けることとします。
 ※RIP/EIGRPへConnected/Staticを再配送する時には、シードメトリックはデフォルトで「1」になります。
 設定確認のために、Router_Aの「show ip protocols」とcatalyst3750-1のルーティングテーブルを確認します。
Router_A#sh ip protocols
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 192.168.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    connected, includes subnets in redistribution
    static, includes subnets in redistribution
    eigrp 1 with metric mapped to 10, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    1.0.0.0 0.0.0.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.0.253        110      22:50:11
  Distance: (default is 110)
  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.16.1.2            90      00:33:17
  Distance: internal 90 external 170
 connectedとstaticをサブネット含めて再配送という設定が読み取れます。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O E2 172.17.0.0/16 [110/20] via 1.0.0.241, 00:04:11, Vlan2
O E2 172.16.0.0/16 [110/20] via 1.0.0.241, 00:04:21, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:04:11, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
O E2 192.168.100.0/24 [110/20] via 1.0.0.241, 00:48:28, Vlan2
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 シードメトリック(20)やメトリックタイプ(E2)がデフォルトのまま再配送され、経路を学習しているがわかります。
 シードメトリックついてはこちらを参照してください。

●再配送Distance値

experiment12-x.png

 設定条件は
  • Router_BとRouter_DにおいてRIPの経路情報をOSPFへ再配送する
  • 経路が最適になるようDistance値を設定する
 基本設定は完了しており、「catalyst3750-1」のみRIPの再配送、OSPFの再配送が設定されている状態とします。この時点での各ネットワーク機器のルーティング情報は下記のとおりです。
catalyst3750-1のルーティング情報
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_Aのルーティング情報
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
Router_Bのルーティング情報
Router_B#sh ip route
Gateway of last resort is not set
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
Router_Dのルーティング情報
Router_D#sh ip route
Gateway of last resort is not set
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
Router_Cのルーティング情報
Router_C#sh ip route
Gateway of last resort is not set
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.1/32 is directly connected, FastEthernet1
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Loopback0
L        192.168.100.1/32 is directly connected, Loopback0
 Router_AにOSPF(area 0)を設定します。
!
router ospf 1
 network 1.0.0.0 0.0.0.255 area 0
 network 171.16.0.0 0.0.255.255 area 0
 network 171.41.0.0 0.0.255.255 area 0
!
 ここでRouter_Aのルーティング情報を確認します。
Router_A#sh ip route  
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/2] via 1.0.0.254, 00:00:56, Vlan2
 「192.168.0.0/24」が伝搬されている事が分かります。
 catalyst3750-1のルーティング情報も確認します。
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 02:15:28, Vlan2
O    172.41.0.0/16 [110/2] via 1.0.0.241, 02:15:28, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
 Router_Aから「172.16.0.0/16」「172.41.0.0/16」が伝搬されているのが分かります。
 Router_BとRouter_DにOSPF及びRIPを設定します。
Router_Bの設定
!
router ospf 1
 redistribute rip subnets
 network 172.16.0.0 0.0.255.255 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 2
 network 172.40.0.0
!
Router_Dの設定
!
router ospf 1
 redistribute rip subnets
 network 172.41.0.0 0.0.255.255 area 0
!
router rip
 version 2
 redistribute ospf 1 metric 2
 network 172.42.0.0
!         
catalyst3750-1のルーティング情報
catalyst3750-1#sh ip route
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 00:10:48, Vlan2
O E2 172.42.0.0/16 [110/20] via 1.0.0.241, 00:00:09, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:10:48, Vlan2
O    172.41.0.0/16 [110/2] via 1.0.0.241, 00:10:48, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_Bのルーティング情報
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 00:24:16, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
O     172.41.0.0/16 [110/2] via 172.16.1.1, 00:24:16, Vlan10
O E2  172.42.0.0/16 [110/20] via 172.16.1.1, 00:04:59, Vlan10
O     192.168.0.0/24 [110/3] via 172.16.1.1, 00:24:16, Vlan10
Router_Dのルーティング情報
Router_D#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.41.1.1, 00:17:20, FastEthernet0
O     172.16.0.0/16 [110/2] via 172.41.1.1, 00:17:20, FastEthernet0
O E2  172.40.0.0/16 [110/20] via 172.41.1.1, 00:17:20, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/3] via 172.41.1.1, 00:17:20, FastEthernet0
 では、Router_Cを設定します。
!
router rip
 version 2
 network 172.40.0.0
 network 172.42.0.0
 network 192.168.100.0
!
 各機器のルーティング情報を確認します。
catalyst3750-1のルーティング情報
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 00:34:46, Vlan2
O E2 172.42.0.0/16 [110/20] via 1.0.0.241, 00:24:07, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:34:46, Vlan2
O    172.41.0.0/16 [110/2] via 1.0.0.241, 00:34:46, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
O E2 192.168.100.0/24 [110/20] via 1.0.0.241, 00:00:46, Vlan2
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_Aのルーティング情報
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
O E2  172.40.0.0/16 [110/20] via 172.16.1.2, 00:43:34, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
O E2  172.42.0.0/16 [110/20] via 172.41.1.2, 00:27:06, FastEthernet1
O     192.168.0.0/24 [110/2] via 1.0.0.254, 1d09h, Vlan2
O E2  192.168.100.0/24 [110/20] via 172.16.1.2, 00:03:46, FastEthernet0
Router_Bのルーティング情報
Router_B#sh ip rou   
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 00:48:28, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
O     172.41.0.0/16 [110/2] via 172.16.1.1, 00:48:28, Vlan10
O E2  172.42.0.0/16 [110/20] via 172.16.1.1, 00:29:11, Vlan10
O     192.168.0.0/24 [110/3] via 172.16.1.1, 00:48:28, Vlan10
R     192.168.100.0/24 [120/1] via 172.40.1.2, 00:00:14, FastEthernet0
Router_Dのルーティング情報
Router_D#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.41.1.1, 00:36:48, FastEthernet0
O     172.16.0.0/16 [110/2] via 172.41.1.1, 00:36:48, FastEthernet0
O E2  172.40.0.0/16 [110/20] via 172.41.1.1, 00:36:48, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/3] via 172.41.1.1, 00:36:48, FastEthernet0
O E2  192.168.100.0/24 [110/20] via 172.41.1.1, 00:02:38, FastEthernet0
Router_Cのルーティング情報
Router_C#sh ip route
Gateway of last resort is not set
R     1.0.0.0/8 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
R     172.16.0.0/16 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                    [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.2/32 is directly connected, FastEthernet0
R     172.41.0.0/16 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                    [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.1/32 is directly connected, FastEthernet1
R     192.168.0.0/24 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                     [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Loopback0
L        192.168.100.1/32 is directly connected, Loopback0
 赤字部分に注目します。RIPのネットワークにある「172.40.0.0/16」と「192.168.100.0/24」をOSPF経由で学習しています。Router_Dは、「172.40.0.0/16」と「192.168.100.0/24」をRIP経由とOSPF経由の両方から学習し、OSPFを採用したことになります。
 ※Router_BでRIPの経路情報「192.168.100.0/24」が存在しているのは、Router_D上でRIPの経路が存在しないために、再配送していないからです。Router_Dに再配送の設定を先にしたためであり、タイミングによります。
 これはRIPよりもOSPFのAD値(アドミニストレーティブディスタンス値)が低くため、より優先されたからです。RIPとOSPFのAD値(アドミニストレーティブディスタンス値)は、「show ip protocols」で確認できます。
Router_D#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.42.1.2
  It is an autonomous system boundary router
  Redistributing External Routes from,
    rip, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.41.0.0 0.0.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          110      01:15:19
    172.42.1.1           110      00:41:09
    192.168.0.253        110      01:15:19
  Distance: (default is 110)
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 16 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: ospf 1, rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet1         2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.42.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.42.1.1           120      00:00:22
  Distance: (default is 120)
 デフォルトのAD値は、RIPで「120」、OSPFでは「110」です。

experiment13-x.png

 OSPFから学習した「172.40.1.0/16」と「192.168.100.0/24」は最適な経路ではないので、RIPで学習した「172.40.1.0/16」と「192.168.100.0/24」を優先するように工夫する必要があります。Router_Dは経路を採用する際に、AD値を比較しています。なのでこのAD値を変更することでRIPの経路を優先させることができます。
Router_D#conf t     
Enter configuration commands, one per line.  End with CNTL/Z.
Router_D(config)#access-list 1 permit 127.40.1.0    
Router_D(config)#access-list 1 permit 192.168.100.0
Router_D(config)#router rip
Router_D(config-router)#distance 109 0.0.0.0 255.255.255.255 1
Router_D(config)#^Z
 経路情報を指定するためアクセスリストを作成します。ルータコンフィグレーションモードで、「distance」コマンドを使用しAD値を設定します。「109」はAD値、「0.0.0.0 255.255.255.255」は経路情報の送信元、最後の数字「1」は経路情報の指定をするためのアクセスリスト番号です。
 設定完了後に、Router_Dのルーティングテーブルを確認します。
Router_D#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.41.1.1, 12:47:13, FastEthernet0
O     172.16.0.0/16 [110/2] via 172.41.1.1, 12:47:13, FastEthernet0
R     172.40.0.0/16 [109/1] via 172.42.1.1, 00:00:15, FastEthernet1
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/3] via 172.41.1.1, 12:47:13, FastEthernet0
R     192.168.100.0/24 [109/1] via 172.42.1.1, 00:00:15, FastEthernet1
 経路が最適になったことがわかります。
 Router_Dも同様に設定します。
Router_B#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router_B(config)#access-list 1 permit 172.42.0.0
Router_B(config)#access-list 1 permit 192.168.100.0
Router_B(config)#router rip
Router_B(config-router)#distance 109 0.0.0.0 255.255.255.255 1
Router_B(config-router)#^Z
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 14:57:13, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
O     172.41.0.0/16 [110/2] via 172.16.1.1, 00:58:20, Vlan10
R     172.42.0.0/16 [109/1] via 172.40.1.2, 00:00:21, FastEthernet0
O     192.168.0.0/24 [110/3] via 172.16.1.1, 14:57:13, Vlan10
R     192.168.100.0/24 [109/1] via 172.40.1.2, 00:00:21, FastEthernet0
 RIPの経路がAD値「109」で学習されており、最適な経路を採用したことがわかります。
Router_B#sh ip protocols 
*** IP Routing is NSF aware ***
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 172.42.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 1 with metric mapped to 10
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.0.0 0.0.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          110      01:26:22
    172.42.1.2           110      01:23:11
    1.0.2.254            110      15:25:14
  Distance: (default is 110)
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 7 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: ospf 1, rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0         2     2                                    
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    172.40.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.40.1.2           109      00:00:27
  Distance: (default is 120)
    Address         Wild mask       Distance  List
    0.0.0.0         255.255.255.255      109  1
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP-IPv4 Protocol for AS(1)
    Metric weight K1=1, K2=0, K3=1, K4=0, K5=0
    NSF-aware route hold timer is 240
    Router-ID: 172.42.1.1
    Topology : 0 (base) 
      Active Timer: 3 min
      Distance: internal 90 external 170
      Maximum path: 4
      Maximum hopcount 100
      Maximum metric variance 1
  Automatic Summarization: disabled
  Maximum path: 4
  Routing for Networks:
    172.17.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    172.17.1.2            90      14:54:37
  Distance: internal 90 external 170

●再配送 Distribute-list

experiment12-x.png

 設定条件は
  • Router_BとRouter_DにおいてRIPの経路情報をOSPFへ再配送する
  • 経路が最適になるようDistance値を設定する

 各ルータにホスト名、IPアドレス、ルーティング設定、再配送設定を行います。コンフィグレーションについては、●再配送Distance値の基本設定を使用します。
 初期設定用のconfigはここからダウンロードできます。
 Distance値を設定する直前のルーティングプロセスの境界ルータ(Router_BとRouter_D)のルーティングテーブルを確認します。
catalyst3750-1のルーティング情報
Gateway of last resort is 1.0.0.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
C       1.0.0.0 is directly connected, Vlan2
O    172.16.0.0/16 [110/2] via 1.0.0.241, 00:34:46, Vlan2
O E2 172.42.0.0/16 [110/20] via 1.0.0.241, 00:24:07, Vlan2
O E2 172.40.0.0/16 [110/20] via 1.0.0.241, 00:34:46, Vlan2
O    172.41.0.0/16 [110/2] via 1.0.0.241, 00:34:46, Vlan2
C    192.168.0.0/24 is directly connected, FastEthernet1/0/23
O E2 192.168.100.0/24 [110/20] via 1.0.0.241, 00:00:46, Vlan2
S*   0.0.0.0/0 [1/0] via 1.0.0.1
Router_Aのルーティング情報
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, FastEthernet0
L        172.16.1.1/32 is directly connected, FastEthernet0
O E2  172.40.0.0/16 [110/20] via 172.16.1.2, 00:43:34, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
O E2  172.42.0.0/16 [110/20] via 172.41.1.2, 00:27:06, FastEthernet1
O     192.168.0.0/24 [110/2] via 1.0.0.254, 1d09h, Vlan2
O E2  192.168.100.0/24 [110/20] via 172.16.1.2, 00:03:46, FastEthernet0
Router_Bのルーティング情報
Router_B#sh ip rou   
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 00:48:28, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
O     172.41.0.0/16 [110/2] via 172.16.1.1, 00:48:28, Vlan10
O E2  172.42.0.0/16 [110/20] via 172.16.1.1, 00:29:11, Vlan10
O     192.168.0.0/24 [110/3] via 172.16.1.1, 00:48:28, Vlan10
R     192.168.100.0/24 [120/1] via 172.40.1.2, 00:00:14, FastEthernet0
Router_Dのルーティング情報
Router_D#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.41.1.1, 00:36:48, FastEthernet0
O     172.16.0.0/16 [110/2] via 172.41.1.1, 00:36:48, FastEthernet0
O E2  172.40.0.0/16 [110/20] via 172.41.1.1, 00:36:48, FastEthernet0
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/3] via 172.41.1.1, 00:36:48, FastEthernet0
O E2  192.168.100.0/24 [110/20] via 172.41.1.1, 00:02:38, FastEthernet0
Router_Cのルーティング情報
Router_C#sh ip route
Gateway of last resort is not set
R     1.0.0.0/8 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
R     172.16.0.0/16 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                    [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.2/32 is directly connected, FastEthernet0
R     172.41.0.0/16 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                    [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.1/32 is directly connected, FastEthernet1
R     192.168.0.0/24 [120/2] via 172.42.1.2, 00:00:07, FastEthernet1
                     [120/2] via 172.40.1.1, 00:00:18, FastEthernet0
      192.168.100.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.100.0/24 is directly connected, Loopback0
L        192.168.100.1/32 is directly connected, Loopback0
 緑字の部分を見ると、RIPにある「172.40.0.0/16」「172.42.0.0/16」「192.168.100.0/24」をOSPF経由で学習しています。
 Router_Bは「172.42.0.0/16」を、Router_Dは「172.40.0.0/16」「192.168.100.0/24」をRIP経由経由OSPF経由両方から学習し、OSPF経由の経路をルーティングテーブルに採用したことになります。
 Router_DでRIPの経路情報「192.168.100.0/24」が存在しているのは、Router_D上でRIPの経路が存在していないために再配送していないからです。Router_Bに再配送の設定を先にしたためであり、タイミングによります。
 これはRIPよりもOSPFのAD値(アドミニストレーティブディスタンス値)が低くため、より優先されたからです。RIPとOSPFのAD値(アドミニストレーティブディスタンス値)は、「show ip protocols」で確認できます。
 OSPFから学習した「172.40.0.0/16」「172.42.0.0/16」「192.168.100.0/24」最適な経路ではないので、RIPで学習した「172.40.0.0/16」「172.42.0.0/16」「192.168.100.0/24」を優先するように工夫する必要があります。今回はルーティングアップデートを制御することで、対応します。
 Router_BはOSPF経由での「172.42.0.0/16」を受信しないように、Router_DはOSPF経由での「172.40.0.0/16」「192.168.100.0/24」を受信しないように、ルーティングアップデートを制御します。

experiment14-x.png

 ※OSPFのルーティングアップデートには、Router_BとRouter_Dの直接接続の経路は含めていません。OSPF経由でアップデートを受信したとしても直接接続がAD値で優先されます。
 ルーティングアップデートを制御する(フィルタリング)方法には、複数ありますが、今回は「Distribute-list(ディストリビュートリスト)」を使用します。distribute-listの手順は2ステップです。
  • 1、フィルタリングするネットワークアドレスを指定したアクセスリストを作成する
  • 2、distribute-listコマンドで、着信/発信インタフェースでのフィルタリング設定を作成
 まずはアクセスリストを作成します。
 Router_Bでは、OSPF経由での「172.40.0.0/16」「192.168.100.0/24」を拒否するアクセスリストを作成します。
!
access-list 1 deny   172.42.0.0 0.0.255.255
access-list 1 deny   192.168.100.0 0.0.0.255
access-list 1 permit any
!
 Router_Dでは、OSPF経由での「172.40.0.0/16」「192.168.100.0/24」を拒否するアクセスリストを作成します。
!
access-list 1 deny   172.40.0.0 0.0.255.255
access-list 1 deny   192.168.100.0 0.0.0.255
access-list 1 permit any
!
 distribute-list(ディストリビュートリスト)で扱うアクセスリストは、通常のアクセスリストの様に送信元アドレスをチェックしてフィルタリングするのではなく、経路情報の先頭から何ビットを確認するという指定になります。ワイルドカードマスクは、サブネットを表しているのではなく、あくまで先頭から何ビットまでをチェックするかというだけです。サブネットも含めてフィルタリングする場合は、プレフィックスリスト等を使用します。最後に暗黙のdenyがあるので、「permit any」が必要です。
 もし「permit any」を設定しない場合は、全ての拒否と同じになり、OSPF経由で経路情報を受け取りません。

 次に2番目のステップである、distribute-list(ディストリビュートリスト)を設定します。
Router_Bの設定
!
router ospf 1
 redistribute rip subnets
 redistribute eigrp 1 metric 10
 network 172.16.0.0 0.0.255.255 area 0
 distribute-list 1 in Vlan10
!
Router_Dの設定
!
router ospf 1
 redistribute rip subnets
 network 172.41.0.0 0.0.255.255 area 0
 distribute-list 1 in FastEthernet0
!
 数字の「1」はアクセスリストを指定します。「in」はアクセスリストを着信ルーティングアップデートに適用します。「Vlan10」「FastEthernet0」はアップデートをフィルタリングするインタフェース名になります。
※OSPFはインタフェースから発信するルーティングアップデートには適用できません。
※インタフェースを指定しない場合は、すべてのインタフェースが対象になります。
 distribute-list(ディストリビュートリスト)は「in」「out」で指定できるオプションが違います。
 distribute-list {ACL number} in {interface}
 distribute-list {ACL number} out {interface | routing-process}
の様に、「distribute-list in」コマンドはインタフェースの指定のみですが、
 「distribute-list out」コマンドは、インタフェースだけでなくルーティングプロセスを指定できます。

 distribute-list(ディストリビュートリスト)の設定を確認するために、「show ip protocols」コマンドを使用します。
Router_Bの「show ip protocols」
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
    Vlan10 filtered by 1 (per-user), default is not set
  Router ID 172.42.1.1
  It is an autonomous system boundary router
 Redistributing External Routes from,
    rip, includes subnets in redistribution
    eigrp 1 with metric mapped to 10
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.16.0.0 0.0.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          110      00:48:09
    172.42.1.2           110      00:46:58
    1.0.2.254            110      00:48:09
  Distance: (default is 110)
~省略~
Router_Dの「show ip protocols」
Routing Protocol is "ospf 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
    FastEthernet0 filtered by 1 (per-user), default is not set
  Router ID 172.42.1.2
  It is an autonomous system boundary router
  Redistributing External Routes from,
    rip, includes subnets in redistribution
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    172.41.0.0 0.0.255.255 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    192.168.1.1          110      00:51:58
    172.42.1.1           110      00:51:58
    1.0.2.254            110      00:51:58
  Distance: (default is 110)
~省略~
 緑字部分でフィルタリング(ディストリビュートリスト)の設定が確認できます。

 次にルーティングプロセスの境界ルータのルーティングテーブルを確認します。
Router_Bの「show ip route」
Router_B#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.16.1.1, 01:03:07, Vlan10
      172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.16.0.0/16 is directly connected, Vlan10
L        172.16.1.2/32 is directly connected, Vlan10
      172.17.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.17.0.0/16 is directly connected, Vlan20
L        172.17.1.1/32 is directly connected, Vlan20
      172.40.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.40.0.0/16 is directly connected, FastEthernet0
L        172.40.1.1/32 is directly connected, FastEthernet0
O     172.41.0.0/16 [110/2] via 172.16.1.1, 01:03:07, Vlan10
R     172.42.0.0/16 [120/1] via 172.40.1.2, 00:00:17, FastEthernet0
O     192.168.0.0/24 [110/3] via 172.16.1.1, 01:03:07, Vlan10
R     192.168.100.0/24 [120/1] via 172.40.1.2, 00:00:17, FastEthernet0
Router_Dの「show ip route」
Router_D#sh ip route
Gateway of last resort is not set
      1.0.0.0/24 is subnetted, 1 subnets
O        1.0.0.0 [110/2] via 172.41.1.1, 01:04:15, FastEthernet0
O     172.16.0.0/16 [110/2] via 172.41.1.1, 01:04:15, FastEthernet0
R     172.40.0.0/16 [120/1] via 172.42.1.1, 00:00:06, FastEthernet1
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet0
L        172.41.1.2/32 is directly connected, FastEthernet0
      172.42.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.42.0.0/16 is directly connected, FastEthernet1
L        172.42.1.2/32 is directly connected, FastEthernet1
O     192.168.0.0/24 [110/3] via 172.41.1.1, 01:04:15, FastEthernet0
R     192.168.100.0/24 [120/1] via 172.42.1.1, 00:00:06, FastEthernet1
 赤字部分の経路情報を確認します。distribute-list(ディストリビュートリスト)を設定する前は、「O E2」というOSPFの外部ネットワーク経路を学習していましたが、distribute-list(ディストリビュートリスト)で外部ネットワークに関する経路情報をフィルタリングした結果、RIPの経路情報(構成図上、最適な経路)が採用されています。

 アクセスリストを反映させたRouter_B、Router_Dのconfigはここからダウンロードできます。

●再配送Route-map(ルートマップ)によるシードメトリック設定

experiment15-x.png

 設定条件
  • 構成図のネットワークを構築
  • RIPの経路情報をOSPFへ再配送する
  • 「10.1.1.0/24」はシードメトリック「50」、「10.1.2.0/25」はシードメトリック「100」、 「10.1.2.128/26」はシードメトリック「150」、「10.1.2.192/27」はシードメトリック「200」でそれぞれ再配送する
 Router_A、Router_D、Router_Cに着目します。それぞれの設定は下記のとおりです。
Router_Aの設定
!
interface FastEthernet1
 ip address 172.41.1.1 255.255.0.0
 duplex auto
 speed auto
!
router ospf 1
 network 1.0.0.0 0.0.0.255 area 0
 network 172.16.0.0 0.0.255.255 area 0
 network 172.41.0.0 0.0.255.255 area 0
!
Router_Dの設定
!
interface FastEthernet0
 ip address 172.41.1.2 255.255.0.0
 duplex auto
 speed auto
!
interface FastEthernet1
 ip address 172.42.1.2 255.255.0.0
 duplex auto
 speed auto
!
router ospf 1
 network 172.41.0.0 0.0.255.255 area 0
!
router rip
 version 2
 network 172.42.0.0
!
Router_Cの設定
!
interface Loopback0
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.2.1 255.255.255.128
!
interface Loopback2
 ip address 10.1.2.129 255.255.255.192
!
interface Loopback3
 ip address 10.1.2.193 255.255.255.224
!         
interface FastEthernet1
 ip address 172.42.1.1 255.255.0.0
 duplex auto
 speed auto
!
router rip
 version 2
 network 172.42.0.0
 network 192.168.101.0
 no auto-summary
!
 Router_Dでシードメトリックを指定せずにRIPの経路情報をOSPFへ再配送します。双方向で通信ができるようにRouter_Cにはデフォルトルートを設定します。
Router_Dの設定
!
router ospf 1
 redistribute rip subnets
 network 172.41.0.0 0.0.255.255 area 0
!
Router_Cの設定
!
ip route 0.0.0.0 0.0.0.0 172.42.1.2
!
 Router_AにRIPの経路情報が再配送されているか確認します。
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
O E2     10.1.1.0/24 [110/20] via 172.41.1.2, 00:00:31, FastEthernet1
O E2     10.1.2.0/25 [110/20] via 172.41.1.2, 00:00:31, FastEthernet1
O E2     10.1.2.128/26 [110/20] via 172.41.1.2, 00:00:31, FastEthernet1
O E2     10.1.2.192/27 [110/20] via 172.41.1.2, 00:00:31, FastEthernet1
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
O E2  172.42.0.0/16 [110/20] via 172.41.1.2, 3d00h, FastEthernet1
 緑字部分を確認します。Router_Dにより再配送された経路情報が確認できます。再配送設定にメトリックの設定をしていないので、シードメトリックはデフォルトの「20」になっています。

 Route-map(ルートマップ)によるシードメトリックを設定します。
 redistributeコマンドではメトリックを設定できますが、複数の経路情報ごとにシードメトリックを設定するためには、Route-map(ルートマップ)を使用する必要があります。

 手順は、3段階です。
  • ACLの設定
  • シードメトリックを指定するルート情報を特定するためのACLを作成します。
  • ルートマップの作成
  • グローバルコンフィグレーションモードで「route-map」コマンドを使用しルートマップを作成します。
    構文は、以下の様になります。
    route-map {map-tag} {permit | deny} {sequence-number}
    map-tagは、route-mapを識別するためのタグになります。任意の文字列を設定します。
    permit | denyでは、ルートの許可拒否を指定します。permitが許可、denyが拒否です。
    拒否された場合は、ルート再配送されません。ACLと同じように暗黙のdenyが最後に存在するので注意が必要です。
    sequence-numberは、ルートマップを処理する順番です。小さい方から順番に処理されます。処理された段階で、それ以降のルートマップは確認しません。
    ※ポリシーベースルーティングの際は、permitは指定された方法でルーティング、denyは通常のルーティングを行うという意味になります。

    route-mapコマンドを実行するとルートマップコンフィグレーションモードへ移行します。
    移行後に、
    match ip address {access-list number}
    set metric {metric-value}
    の二つのコマンドを使用し、任意のルート情報にシードメトリックを指定します。
  • 作成したルートマップを再配送時に適用
  • redistribute」にルートマップのオプションと、作成したルートマップを指定します。

     では実際の設定を行います。ルーティングプロセスの境界ルータであるRouter_Dで設定を行います。
Router_DのRouter-map(ルートマップ)設定
  RouterB#conf
  RouterB(config)#access-list 1 permit 10.1.1.0 0.0.0.255
  RouterB(config)#access-list 2 permit 10.1.2.0 0.0.0.127
  RouterB(config)#access-list 3 permit 10.1.2.128 0.0.0.63
  RouterB(config)#access-list 4 permit 10.1.2.192 0.0.0.31
  !--ルートマップでルート情報を指定するためのACL設定する
  RouterB(config)#route-map rip2ospf permit 10
  RouterB(config-route-map)#match ip address 1
  RouterB(config-route-map)#set metric 50
  !--シーケンス番号10番で、「10.1.1.0/24」のルート情報に
  シードメトリック「50」を設定する
  RouterB(config)#route-map rip2ospf permit 20
  RouterB(config-route-map)#match ip address 2
  RouterB(config-route-map)#set metric 100
  !--シーケンス番号20番で、「10.1.2.0/25」のルート情報に
  シードメトリック「100」を設定する
  RouterB(config)#route-map rip2ospf permit 30
  RouterB(config-route-map)#match ip address 3
  RouterB(config-route-map)#set metric 150
  !--シーケンス番号30番で、「10.1.2.128/26」のルート情報に
  シードメトリック「150」を設定する
  RouterB(config)#route-map rip2ospf permit 40
  RouterB(config-route-map)#match ip address 4
  RouterB(config-route-map)#set metric 200
  !--シーケンス番号40番で、「10.1.2.192/27」のルート情報に
  シードメトリック「200」を設定する
  RouterB(config)#route-map rip2ospf permit 50
  !--シーケンス番号10~40に一致しない場合、全て許可する
  RouterB(config)#router ospf 1
  RouterB(config-router)#redistribute rip route-map rip2ospf subnets
注意が必要なのは「暗黙のdeny」があるので、必要に応じて全て許可等の設定をする必要があります。set metric等の指定がないので、デフォルトのシードメトリック「20」がそのまま使用されます。

 Route-map(ルートマップ)を確認します。設定したRoute-map(ルートマップ)の内容を確認するには、「show route-map」コマンドを使用します。
Router_D#sh route-map
route-map rip2ospf, permit, sequence 10
  Match clauses:
    ip address (access-lists): 1 
  Set clauses:
    metric 50
  Policy routing matches: 0 packets, 0 bytes
route-map rip2ospf, permit, sequence 20
  Match clauses:
    ip address (access-lists): 2 
  Set clauses:
    metric 100
  Policy routing matches: 0 packets, 0 bytes
route-map rip2ospf, permit, sequence 30
  Match clauses:
    ip address (access-lists): 3 
  Set clauses:
    metric 150
  Policy routing matches: 0 packets, 0 bytes
route-map rip2ospf, permit, sequence 40
  Match clauses:
    ip address (access-lists): 4 
  Set clauses:
    metric 200
  Policy routing matches: 0 packets, 0 bytes
route-map rip2ospf, permit, sequence 50
  Match clauses:
  Set clauses:
  Policy routing matches: 0 packets, 0 bytes
 赤字部分はシーケンス番号、青字部分はaccess-list番号、緑字部分はsetコマンドで指定した動作(今回はシードメトリックの指定)です。

 Router_Dにより再配送されたルート情報のシードメトリックがRoute-map(ルートマップ)で設定した内容通りの値になっているか確認します。Router_Aのルーティングテーブルを表示させメトリックを確認します。
Router_A#sh ip route
Gateway of last resort is not set
      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/24 is directly connected, Vlan2
L        1.0.0.241/32 is directly connected, Vlan2
      10.0.0.0/8 is variably subnetted, 4 subnets, 4 masks
O E2     10.1.1.0/24 [110/50] via 172.41.1.2, 00:17:09, FastEthernet1
O E2     10.1.2.0/25 [110/100] via 172.41.1.2, 00:17:09, FastEthernet1
O E2     10.1.2.128/26 [110/150] via 172.41.1.2, 00:17:09, FastEthernet1
O E2     10.1.2.192/27 [110/200] via 172.41.1.2, 00:17:09, FastEthernet1
      172.41.0.0/16 is variably subnetted, 2 subnets, 2 masks
C        172.41.0.0/16 is directly connected, FastEthernet1
L        172.41.1.1/32 is directly connected, FastEthernet1
O E2  172.42.0.0/16 [110/20] via 172.41.1.2, 3d18h, FastEthernet1
O     192.168.0.0/24 [110/2] via 1.0.0.254, 2w3d, Vlan2
 赤字部分がRouter-map(ルートマップ)で指定したシードメトリックの値です。再配送の設定通りにシードメトリックが変更されているのがわかります。
 また、青字の経路情報は、シーケンス番号50の全て許可し、何もメトリックを指定しない(デフォルトのまま)に一致した経路情報です。もしシーケンス番号50がなければ「暗黙のdeny」で再配送されることはありません。

◆補足
 Route-map(ルートマップ)は再配送時のフィルタリングだけでなく以下の用途でも使用します。
  • ポリシーペースルーティング
  • BGPのルートフィルタ、パス属性の変更
  • NAT変換アドレスの指定
ポリシーベースルーティング
 ルーティングは通常、宛先IPアドレスにより転送先を決定し、トラフィックをフォワーディングします。Route-map(ルートマップ)を使用すると、宛先IPアドレスだけでなく送信元IPアドレスやTOS値、パケット長、出力インタフェース等に基づいて、転送先を決定しトラフィックをフォワーディングすることができます。
BGPのルートフィルタ、アトリビュートの変更
BGPのアップデートに含まれるルート情報をフィルタしたり、アトリビュートを変更することができます。
NAT変換アドレスの指定
NAT ルートマップ(route-map)を使用したNAT」を参照してください。
 なお、configはここからダウンロードできます。